// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^(([0-1]?\d{1,2})|(2[0-5]{2}))(\.(([0-1]?\d{1,2})|(2[0-5]{2}))){3}$)").unwrap();
let string = "194.115.1.4
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}