import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*\\d)(?=.*[-$_. +!*'()])[\\w$. +!*'()-]{9,39}$";
final String string = "Pas+ad123err0risoK\n"
+ "aA1234+56z\n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}