re = /^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[-$_. +!*'()])[\w$. +!*'()-]{9,39}$/m
str = 'Pas+ad123err0risoK
aA1234+56z
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end