$re = '/^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[-$_. +!*\'()])[\w$. +!*\'()-]{9,39}$/m';
$str = 'Pas+ad123err0risoK
aA1234+56z
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);