const regex = /^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[-$_. +!*'()])[\w$. +!*'()-]{9,39}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z](?=.*[a-z])(?=.*[A-Z])(?=.*\\d)(?=.*[-$_. +!*\'()])[\\w$. +!*\'()-]{9,39}$', 'gm')
const str = `Pas+ad123err0risoK
aA1234+56z
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}