using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">(.*2014.*)<\/year";
string input = @"<title>Record 4m</title><start>2014-02-22</start><year>2013</year><year_0>like 2015 this</year_0><end>2014-03-01</end>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}