re = />(.*2014.*)<\/year/
str = '<title>Record 4m</title><start>2014-02-22</start><year>2013</year><year_0>like 2015 this</year_0><end>2014-03-01</end>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end