package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>(.*2014.*)<\/year`)
var str = `<title>Record 4m</title><start>2014-02-22</start><year>2013</year><year_0>like 2015 this</year_0><end>2014-03-01</end>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}