using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\w+[:digit:],][\w+[:digit:],][\w+[:digit:],])";
string input = @"R-P010328-P02-500-1,70";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}