package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[\w+[:digit:],][\w+[:digit:],][\w+[:digit:],])`)
var str = `R-P010328-P02-500-1,70`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}