$re = '/(?:[\w+[:digit:],][\w+[:digit:],][\w+[:digit:],])/';
$str = 'R-P010328-P02-500-1,70';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);