using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\$\/(?:[\w ]+\/)+[\w ]+(?:\.\w+)+)";
string input = @"Hello,
You can download the file here:
- $/Server/First Level Folder/Second_Level_Folder/My File.extension <- Click me!
- $/Server/First Level Folder/Second_Level_Folder/My File.tar.gz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}