$re = '/(\$\/(?:[\w ]+\/)+[\w ]+(?:\.\w+)+)/';
$str = 'Hello,
You can download the file here:
- $/Server/First Level Folder/Second_Level_Folder/My File.extension <- Click me!
- $/Server/First Level Folder/Second_Level_Folder/My File.tar.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);