// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\$\/(?:[\w ]+\/)+[\w ]+(?:\.\w+)+)").unwrap();
let string = "Hello,
You can download the file here:
- $/Server/First Level Folder/Second_Level_Folder/My File.extension <- Click me!
- $/Server/First Level Folder/Second_Level_Folder/My File.tar.gz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}