import re
regex = re.compile(r"(\$\/(?:[\w ]+\/)+[\w ]+(?:\.\w+)+)")
test_str = ("Hello,\n\n"
"You can download the file here:\n\n"
"- $/Server/First Level Folder/Second_Level_Folder/My File.extension <- Click me!\n\n"
"- $/Server/First Level Folder/Second_Level_Folder/My File.tar.gz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")