#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(?:#|\s)\s*"
Local $sString = "#ab#ab #ab # ab # a #a" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ab ab ab ab a a "
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)