$re = '/\s*(?:#|\s)\s*/m';
$str = '#ab#ab #ab # ab # a #a
ab ab ab ab a a ';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;