re = /\s*(?:#|\s)\s*/m
str = '#ab#ab #ab # ab # a #a
ab ab ab ab a a '
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result