const regex = /\s*(?:#|\s)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?:#|\\s)\\s*', 'gm')
const str = `#ab#ab #ab # ab # a #a
ab ab ab ab a a `;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);