#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\/?\w+(:)\w+>"
Local $sString = "<data:data>" & @CRLF & _
" <another:data>Content:content</another:data>" & @CRLF & _
" <another:data>Content</another:data>" & @CRLF & _
" <another:data>Content</another:data>" & @CRLF & _
" <another:data>Name:Foo</another:data>" & @CRLF & _
"</data:data>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")