$re = '/<\/?\w+(:)\w+>/m';
$str = '<data:data>
<another:data>Content:content</another:data>
<another:data>Content</another:data>
<another:data>Content</another:data>
<another:data>Name:Foo</another:data>
</data:data>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);