re = /<\/?\w+(:)\w+>/m
str = '<data:data>
<another:data>Content:content</another:data>
<another:data>Content</another:data>
<another:data>Content</another:data>
<another:data>Name:Foo</another:data>
</data:data>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end