import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:(?:(?<!^)[ ])?[^*&@_#$\\]\\\\\\^\\d ]+){1,3})$";
final String string = "Uwe\n"
+ "Uwe-Jens\n"
+ "Günther Kalle\n"
+ "Kalle Jens Chantal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}