$re = '/^((?:(?:(?<!^)[ ])?[^*&@_#$\]\\\\\^\d ]+){1,3})$/mu';
$str = 'Uwe
Uwe-Jens
Günther Kalle
Kalle Jens Chantal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);