#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Test((_[A-Za-z0-9]+)\1*)"
Local $sString = "Test_Interface extends" & @CRLF & _
"Test_Interface_Foo_Bar {" & @CRLF & _
"Test_FooBar implements" & @CRLF & _
"Test_FooBarFoo_Bar_Bar_Foo"
Local $sSubst = "\\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)