import Foundation
let pattern = #"^Test((_[A-Za-z0-9]+)\1*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)