#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*\/changelogs(?:\/|$)).*\/(\d+)"
Local $sString = "http://www.opera.com/docs/changelogs/unified/1215/" & @CRLF & _
"http://www.whatever.com/docs/changelogs/anythingelse/anything/1215/" & @CRLF & _
"http://www.blabblah/security/advisory/1047" & @CRLF & _
"http://booger/security/advisory/1048/" & @CRLF & _
"ftp://msn.global.whatever/somethingelse/1245" & @CRLF & _
"whatever/it/doesnt/matter/could/be/anything/i/still/want/this/number/1049/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")