import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\/changelogs(?:\\/|$)).*\\/(\\d+)";
final String string = "http://www.opera.com/docs/changelogs/unified/1215/\n"
+ "http://www.whatever.com/docs/changelogs/anythingelse/anything/1215/\n"
+ "http://www.blabblah/security/advisory/1047\n"
+ "http://booger/security/advisory/1048/\n"
+ "ftp://msn.global.whatever/somethingelse/1245\n"
+ "whatever/it/doesnt/matter/could/be/anything/i/still/want/this/number/1049/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}