re = /^(?!.*\/changelogs(?:\/|$)).*\/(\d+)/mi
str = 'http://www.opera.com/docs/changelogs/unified/1215/
http://www.whatever.com/docs/changelogs/anythingelse/anything/1215/
http://www.blabblah/security/advisory/1047
http://booger/security/advisory/1048/
ftp://msn.global.whatever/somethingelse/1245
whatever/it/doesnt/matter/could/be/anything/i/still/want/this/number/1049/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end