using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Lic(?:en[cs]e)?(?:\W*No:)?\W*\d+";
string input = @"License No: 2543 , License: 2543, License # 2543, License #2543, License# 2543";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}