$re = '/Lic(?:en[cs]e)?(?:\W*No:)?\W*\d+/';
$str = 'License No: 2543 , License: 2543, License # 2543, License #2543, License# 2543';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);