re = /Lic(?:en[cs]e)?(?:\W*No:)?\W*\d+/
str = 'License No: 2543 , License: 2543, License # 2543, License #2543, License# 2543'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end