package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Lic(?:en[cs]e)?(?:\W*No:)?\W*\d+`)
var str = `License No: 2543 , License: 2543, License # 2543, License #2543, License# 2543`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}