#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):(?=[^<>:]+>)"
Local $sString = "<ns:Documents>" & @CRLF & _
"<ns:Owner>" & @CRLF & _
"<ns:data>полезные:данные:которые:могут:быть разделены двоеточием</ns:data>" & @CRLF & _
"</ns:Owner>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")