import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":(?=[^<>:]+>)";
final String string = "<ns:Documents>\n"
+ "<ns:Owner>\n"
+ "<ns:data>полезные:данные:которые:могут:быть разделены двоеточием</ns:data>\n"
+ "</ns:Owner>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}