re = /:(?=[^<>:]+>)/m
str = '<ns:Documents>
<ns:Owner>
<ns:data>полезные:данные:которые:могут:быть разделены двоеточием</ns:data>
</ns:Owner>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end