#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^[`]\K | (?<=\G) (?>{.*?}|[^`]) \K [^{}`]+"
Local $sString = "`{string} with {exluded} words 12 nums`" & @CRLF & _
"`string {with} {exluded} words 12 nums`" & @CRLF & _
""quoted {string} with {exluded} words and 12 nums"" & @CRLF & _
""quoted string {with} exluded {words} and {12} nums""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")