re = /^[`]\K | (?<=\G) (?>{.*?}|[^`]) \K [^{}`]+/xm
str = '`{string} with {exluded} words 12 nums`
`string {with} {exluded} words 12 nums`
"quoted {string} with {exluded} words and 12 nums"
"quoted string {with} exluded {words} and {12} nums"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end