const regex = /^[`]\K | (?<=\G) (?>{.*?}|[^`]) \K [^{}`]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[`]\\K | (?<=\\G) (?>{.*?}|[^`]) \\K [^{}`]+', 'gm')
const str = `\`{string} with {exluded} words 12 nums\`
\`string {with} {exluded} words 12 nums\`
"quoted {string} with {exluded} words and 12 nums"
"quoted string {with} exluded {words} and {12} nums"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}