const regex = new RegExp('company\\s+(?!\\([A-Z]+:\\s*[A-Z]+\\))', 'gm')
const str = `The company was acquired by Xerox (NYSE: XRX) for \$225 million on May 6, 2014.
The company (NASDAQ:EPOC) was acquired by Athenahealth (NASDAQ:ATHN) for \$293 million in cash on January 7, 2013.
The company is acquired by New Mountain Capital for \$225 million through an LBO on December 18, 2015. FS Investments provided unitranche term loan financing to support the acquisition by New Mountain Capital.
The company was acquired by HTC Global Services for \$97.5 million on December 18, 2014.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}