use strict;
my $str = 'The company was acquired by Xerox (NYSE: XRX) for $225 million on May 6, 2014.
The company (NASDAQ:EPOC) was acquired by Athenahealth (NASDAQ:ATHN) for $293 million in cash on January 7, 2013.
The company is acquired by New Mountain Capital for $225 million through an LBO on December 18, 2015. FS Investments provided unitranche term loan financing to support the acquisition by New Mountain Capital.
The company was acquired by HTC Global Services for $97.5 million on December 18, 2014.
';
my $regex = qr/company\s+(?!\([A-Z]+:\s*[A-Z]+\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}