import re
regex = re.compile(r"company\s+(?!\([A-Z]+:\s*[A-Z]+\))", flags=re.MULTILINE)
test_str = ("The company was acquired by Xerox (NYSE: XRX) for $225 million on May 6, 2014.\n"
"The company (NASDAQ:EPOC) was acquired by Athenahealth (NASDAQ:ATHN) for $293 million in cash on January 7, 2013.\n"
"The company is acquired by New Mountain Capital for $225 million through an LBO on December 18, 2015. FS Investments provided unitranche term loan financing to support the acquisition by New Mountain Capital.\n"
"The company was acquired by HTC Global Services for $97.5 million on December 18, 2014.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")