$re = '/company\s+(?!\([A-Z]+:\s*[A-Z]+\))/m';
$str = 'The company was acquired by Xerox (NYSE: XRX) for $225 million on May 6, 2014.
The company (NASDAQ:EPOC) was acquired by Athenahealth (NASDAQ:ATHN) for $293 million in cash on January 7, 2013.
The company is acquired by New Mountain Capital for $225 million through an LBO on December 18, 2015. FS Investments provided unitranche term loan financing to support the acquisition by New Mountain Capital.
The company was acquired by HTC Global Services for $97.5 million on December 18, 2014.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);