#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,2}\s+\p{L}{3}\s+\d{1,2},\s+\d{1,2}:\d{1,2}"
Local $sString = "Отношения между Индией и Россией были одними из самых глубоких дружеских отношений в мировой истории. 27 апр 21, 01:42 Русские и индийцы невероятно любят и уважают друг друга."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")