package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}\s+\p{L}{3}\s+\d{1,2},\s+\d{1,2}:\d{1,2}`)
var str = `Отношения между Индией и Россией были одними из самых глубоких дружеских отношений в мировой истории. 27 апр 21, 01:42 Русские и индийцы невероятно любят и уважают друг друга.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}