re = /\d{1,2}\s+\p{L}{3}\s+\d{1,2},\s+\d{1,2}:\d{1,2}/m
str = 'Отношения между Индией и Россией были одними из самых глубоких дружеских отношений в мировой истории. 27 апр 21, 01:42 Русские и индийцы невероятно любят и уважают друг друга.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end