use strict;
my $str = 'Отношения между Индией и Россией были одними из самых глубоких дружеских отношений в мировой истории. 27 апр 21, 01:42 Русские и индийцы невероятно любят и уважают друг друга.';
my $regex = qr/\d{1,2}\s+\p{L}{3}\s+\d{1,2},\s+\d{1,2}:\d{1,2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}