using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.?|(?!Miss)(^|.)(?!Mrs)(^|.)(?![MD]r).{2})\. *\b\w+\b";
string input = @"Mr. Foo
Mrs. bar
Hello Dr. Buzz
Testing Miss. Bloggs
Miss. Nomatch
This Mr. Does not Dr. Match Mrs. Test
This should. Match
Also. Match
. Match
A. Match
An. Match";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}