$re = '/(^.?|(?!Miss)(^|.)(?!Mrs)(^|.)(?![MD]r).{2})\. *\b\w+\b/mi';
$str = 'Mr. Foo
Mrs. bar
Hello Dr. Buzz
Testing Miss. Bloggs
Miss. Nomatch
This Mr. Does not Dr. Match Mrs. Test
This should. Match
Also. Match
. Match
A. Match
An. Match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);