import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.?|(?!Miss)(^|.)(?!Mrs)(^|.)(?![MD]r).{2})\\. *\\b\\w+\\b";
final String string = "Mr. Foo\n"
+ "Mrs. bar\n"
+ "Hello Dr. Buzz\n"
+ "Testing Miss. Bloggs\n"
+ "Miss. Nomatch\n"
+ "This Mr. Does not Dr. Match Mrs. Test\n\n"
+ "This should. Match\n"
+ "Also. Match\n"
+ ". Match\n"
+ "A. Match\n"
+ "An. Match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}